Firs I must say wow, the Beast JR is the bet sounding amp I ever build so far (build two other designs of Bruc before). So lifelike after about 20 hours of play. Piano never sounded so full authority. But after a week (60 hours of us) fuses started to blow.

Found out 2 grids on the EL 509 had severe leakage. Exchanged these tubes for others and adjusted the bias all was playing great again. Then after a couple of days again fuses blown (checked daily the voltage on the speaker terminal and that one was always solid close to zero).

Took the amp out of the system, took all the HV fuses to the EL509 out, switched the amp on and yes after a short time when the heater was heating up, grid leakage in two more tubes, pulled the -41 volt to -26 volts on the tube pin on one and -32 volts on the other tube pin.

Put again new tubes in: following measurements made towards the zero bus after 15 minutes, they look perfect to me:
LS out has 0.01 DC
+168 Volt DC on the fuses towards the zero bus
-168 Volt DC on the fuses towards the zero bus
Fixed grid voltage -209.5 volt DC towards the zero bus
Adjustable grid voltage -41.5 volt DC towards the zero bus

On positive tube bank Cathode to grid 41.46 volts DC (measured on the tube pins)
On the negative tube bank Cathode to grid -41-01 volts  DC (measured on the tube pins)

Voltage over each tube heater 6.6 v AC

O yes the tube heater voltage for the positive tube bank is floating. (no connection to ground or other reference voltage)

I listen on very low sound level on a high efficient 98dB speaker system.

This is the first time I work with EL509S from JJ.

Now my questions are:
A) I this failure rate in the beginning normal?
B) If not what can cause this failure rate with me?

Any experiences?  Any thoughts?

I know all designs from Bruce are super reliable and rock solid. I checked all wires and soldering point multiple times 100% sure no error or bad contact there.
Quote 1 0
Robbert
Made a typo here

On positive tube bank Cathode to grid -41.46 volts DC (measured on the tube pins)
On the negative tube bank Cathode to grid -41.01 volts  DC (measured on the tube pins)
Quote 0 0
Anonymous
What makes you think it's "grid leakage" and a tube problem? Grid leakage cannot even be measured decisively in all cases. I assume the Beast Jr is PP . A problem with the bias control/bad parts  seems to be more likely than a whole batch of damaged tubes when so many tubes fail  all of a sudden.

I also would recommend reading chapter 2 (Degenerative failures) of R. Tomer's book: Getting the most out of vaccuum tubes.
Quote 0 0
Wolfgang
I just posted as "anonymous" by mistake. Obviously there is a problem if that is possible.
Quote 0 0
Robbert
Hi Wolfgang, grid leakage can be measured. Apply heater current. NO HV. Apply grid voltage. Use big grid resistor like 100K. If voltage drop over the resistor is significant YES you have grid leakage.
Quote 0 0
Robbert
Hi Wolfgang thanks for directing me to that publication. reading now, very informative.
Quote 0 0
Anonymous
Quote:
grid leakage can be measured

Can be measured of course. What I meant was that there are several components which can cause it, so it's not so easy to  say what exactly causes it.
Quote 0 0
Robbert
An Update.

Tubes were returned and indeed found out of manufacturer specifications. New sets were delivered some days ago and they all play fine.
Great service from Antique Electronic Supply.

Bruce confirmed that indeed all voltages which are measured are fine.

This is the finest sounding amp I have build so far. The music is with full authority and delicacy reproduced.
Quote 0 0
Deleting Attachment...